Группы и рассылки:

Вы здесь

Функции Excel.Функция И(), ИЛИ()

Версия для печати

   На прошлом уроке "Функции Excel. Функция ЕСЛИ" была рассмотрена работа со встроенной функцией ЕСЛИ(). Все бы хорошо, но возникают такие ситуации, и довольно часто, когда вложенностью условия в условие не обойтись. Например, элементарно необходимо проверить следующее: 1 больше или равно x и x меньше или равно 5 . Реализовать такое условие несколькими ЕСЛИ довольно громоздко и проблематично, а в некоторых ситуациях - вообще невозможно. Для расширения функционала ЕСЛИ и облегчения составления формул с условием, в Excel имеются еще пара полезных функции - И() и ИЛИ().

Функция И()

   Функция И() используется тогда, когда необходимо проверить несколько условий следующим образом - Условие 1 И Условие 2. При этом все условия должны быть истинными. Результатом работы данной функции является ИСТИНА или ЛОЖЬ (TRUE / FALSE).  Пример: ЕСЛИ а = b И а=с ТОГДА значение 1 ИНАЧЕ значение 2.
Как видно из примера, значение 1 будет только в том случае, если все условия верны.

 Функция ИЛИ()

   Функция ИЛИ() используется тогда, когда необходимо проверить несколько условий следующим образом - Условие 1 ИЛИ Условие 2. Результат функции будет истинным, если хотя бы одно из условий истинно. Пример: ЕСЛИ а = b ИЛИ а=с ТОГДА значение 1 ИНАЧЕ значение 2.

Синтаксис функций И() и ИЛИ() одинаков: Функция(Условие 1; Условие 2; Условие 3 и до 30-ти условий). Результат ИСТИНА или ЛОЖЬ.

Примеры использования функции И и ИЛИ

Все вышесказанное сложно к пониманию и относится к разделу Мат. логики и Дискретной математики. Попробую это все изложить на понятном языке. Разберем несколько примеров. Скажу сразу, все примеры будут с использованием функции ЕСЛИ.

Пример 1.
Столбец А, начиная с первой строки,  содержит 56, 55, 88, 6, 74. Столбец В - 52, 55, 88, 4, 25. Столбец С - 53, 55, 88, 6, 25. С помощью функций ЕСЛИ и И необходимо определить строки, значения которых равны следующим образом А=В и В=С.

Переходим в ячейку D1 и с помощью мастера функций вводим следующее

функция И пример

Формула будет выглядеть так:  “ =ЕСЛИ(И(A1=B1;B1=C1);"Все значения равны";"Значения не равны") “

Результат работы:

Пример 2.

Теперь пример на функцию ИЛИ. Те же столбцы, те же значения, условие следующее: с помощью функций ЕСЛИ и ИЛИ необходимо определить строки, в  которых есть совпадающие значения  А=В или  В=С или А=С.

Мастер функций выглядит так:

функция ИЛИ пример

Формула: “ =ЕСЛИ(ИЛИ(A1=B1;B1=C1;A1=C1);"Есть равные значения";"Нет равных значений")”

Результат:

Вот и все. Функции не сложны. Применяйте их там, где встречаются условия и произносится И и ИЛИ. Так же, всеми выше перечисленными функциями можно сравнивать текстовые значения.

И напоследок рассмотрим еще один пример с функцией И и ИЛИ из реальной жизни.laugh

Пример 3.

В таблицу занесены процент выполнения заданий, необходимо проценты перевести в пятибалльную систему следующим образом:

1 – от 0% до 10%
2- от 11% до 30%
3- от 31% до 40%
4- от 41% до 75%
5-от 76% до 100%

Таблица следующего вида:

сложные условные формулы в Excel

Составим формулу следующего вида:

=ЕСЛИ(ИЛИ(И(B1>0;B1<0,1);B1=0;B1=0,1);"1";ЕСЛИ(ИЛИ(И(B1>0,11;B1<0,3);B1=0,11;B1=0,3);"2";ЕСЛИ(ИЛИ(И(B1>0,31;B1<0,4);B1=0,31;B1=0,4);"3";ЕСЛИ(ИЛИ(И(B1>0,41;B1<0,75);B1=0,41;B1=0,75);"4";ЕСЛИ((ИЛИ(И(B1>0,76;B1<1);B1=0,76;B1=1));"5";"")))))

Пища для разума wink Почему значения указаны в вещественном виде т.е. 0,41, 0,76, можете прочитать в уроке «Формат данных в Excel»!?

Результат работы формулы:

П.С.: Если есть варианты сократить формулу(а они есть) пишите в комментариях. А пока – пока laugh

 

Прикрепленный файл: func_i_ili_excel.zip

 

 

Автор: 
Deys
Категории: 

Комментарии

т.е. максимальное кол-во аргументов (вариантов ЕСЛИ(ИЛИ(И...) - 3 всего? у меня больше не получается...

 
 
12.02.201525.02.2015
26.02.201511.03.2015
12.03.201525.03.2015
Переделайте табель 
  
 
Как сделать если одна из Диапозона дат совпадает с другими диапозонами дат.
Это график отпуска с и по выходит 14 дней.
Нужно сделать так если одна хотябы дата пересекается в диапозоне, то ее нужно найти ложи или истину, далее как формотировать знаю. Спс.

 
 
Если я правильно понял, Вам необходимо сравнить один столбец с другим и если во втором столбце есть дата из первого то отобразить истина, иначе ЛОЖЬ?
Это можно реализовать с помощью функции ВПР
 
Во вложени пример по Вашему запросу. Верно?
 
 

Можно третий пример и вот так решить:
=ЕСЛИ(B2=100%;5;ЕСЛИ(B2>=76%;5;ЕСЛИ(B2>=41%;4;ЕСЛИ(B2>=31%;3;ЕСЛИ(B2>=11%;2;ЕСЛИ(B2>=0%;1;0))))))

Только надо ставить не 0 а хотя бы 0,5. Чтобы при пустой ячейке не отображалась единица

 

Помогите реализовать допустим если А1=1 и Б1=1 то пиши1,А1=2 и б1=1 пиши 1 ну и в таком продолжении допустимм А1=7 а Б1=4 то пиши 3

 

=ЕСЛИ(И(A1=1;B1=1);1;ЕСЛИ(И(A1=2;B1=1);2;ЕСЛИ(И(A1=7;B1=4);3;0)))

Можно продолжать и дальше..

 

Добавить комментарий

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Строки и параграфы переносятся автоматически.
CAPTCHA
Для предотвращения регистрации спам-роботов введите символы с картинки.
CAPTCHA на основе изображений
Введите символы, изображенные на картинке.
Разместить свое видео на сайте
Вы можете разместить свои 
видео-уроки на сайте
БЕСПЛАТНО!


Подробнее>>>