Группы и рассылки:

Вы здесь

Функции Excel. Функция ЕСЛИ (+видео)

Версия для печати

Функция ЕСЛИ()

Логическая функция ЕСЛИ в Excel применяется в тех случаях, когда необходимо сравнить некоторое кол-во значений и на основе результата принять решение, либо произвести расчеты.

Что значит "логическая функция"?

Логические функции это такие функции, результат работы которых имеет либо "да", либо "нет"(Истина/Ложь), в соответствии с результатом условия выполняется то, или иное действие. Алгоритм работы изображен ниже:

схема работы функции ЕСЛИ в Excel

Функция ЕСЛИ может содержать множество вложенных функций, в том числе и другие функции ЕСЛИ. Синтаксис записи функции ЕСЛИ (Условие 1; Тогда; Иначе) т.е.
Если Условие 1 = Истина
       Тогда Значение1, Формула1, Функция1
   Иначе Значение2, Формула2, Функция2

Как работает  Функция ЕСЛИ() на практике?

Работа с функцией ЕСЛИ() не сложная и легка для понимания. Рассмотрим работу на простых примерах.

Пример 1.
Дан столбец с числами 5,9,25,35,5,9,9,8. Необходимо к каждой ячейке со значением 5 прибавить 2, а от остальных ячеек отнять 6.

Приступим.
Открываем Excel. Вводим значения 5,9,25,35,5,9,9,8 в столбец B начиная со строки 3. Переходим в ячейку С3 и жмем кнопку "Вставка функции":

вставка функции Excel

или главное меню Вставка - Функция...
В открывшемся окне мастера функций, выбираем категорию "Логические" и выделяем функцию ЕСЛИ(), жмем "ОК"

мастер функций Excel

После, появится окно "Аргументы функции", в котором Вам необходимо ввести следующее:

аргументы функции ЕСЛИ в Excel

Примечание: Адреса ячеек можно вводить, щелкая по нужным ячейкам. Для этого необходимо перейти в нужное поле ввода и просто щелкать ЛКМ по ячейкам. Адреса ячеек будут добавляться в поле.

После ввода всех значений и условий, жмем ОК и протягиваем нашу функцию на весь столбец, либо копируем.

Ввод функции можно осуществить и без мастера функций, для этого в ячейку необходимо ввести
"=ЕСЛИ(B3=5;B3+2;B3-6)". Знак "=" обязателен!

Разберем написанное:
«Значение_лог» - задает условие для проверки ячейки, в нашем случае "Если B3 равно 5 (так же доступны ">", "<", "<>", ">=", "<=") тогда выполняется «Значение_если_истина» (B3+2), иначе выполняется «Значение_если_ложь» (B3-6).
Результат:

Пример 2.
Усложним немного нашу задачу. Теперь необходимо следующее, к ячейкам равным 5 добавить 2, равным 9 добавить 10, все остальные оставить пустыми.
Выделяем ячейку D3. Вставляем функцию ЕСЛИ и прописываем все как на снимке:

аргументы функции ЕСЛИ

в результате должна получиться следующая строка: "=ЕСЛИ(B3=5;B3+2;ЕСЛИ(B3=9;B3+10;""))
В данном случае у нас получилось условие с вложенным условием.
В первом условии происходит проверка значения ячейки B3 на равенство с 5. В случае положительного результата, т.е. если равно 5, выполняется "B3+2", иначе выполняется второе условие "B3=9". Если в этом случае результат положительный, то выполняется расчет "B3+10", иначе, результирующую ячейку оставляем пустой "". Блок схема алгоритма ниже:

схема работы вложенных условий ЕСЛИ в Excel

При необходимости вложенность функций ЕСЛИ можно продолжить или комбинировать с другими функциями.

Результат:

На этом закончим рассмотрение работы с функцией ЕСЛИ, но это еще не все. К этой функции мы будем еще часто обращаться по ходу изучения и освоения работы встроенных функций в Excel.

Ниже, Вы можете посмотреть видео-демонстрацию этого урока.

Прикрепленный файл: func_esli.zip

Видео: Работа с функцией ЕСЛИ в Excel

 

Автор: 
Deys
Категории: 

Добавить комментарий

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Строки и параграфы переносятся автоматически.
CAPTCHA
Для предотвращения регистрации спам-роботов введите символы с картинки.
CAPTCHA на основе изображений
Введите символы, изображенные на картинке.
Разместить свое видео на сайте
Вы можете разместить свои 
видео-уроки на сайте
БЕСПЛАТНО!


Подробнее>>>